Ads Forum - Expanded Thread Page

Subject: jubilee pto won't engage

[Back] [Return to Top of Forum]

jim mindy    Posted 04-29-2019 at 17:02:02 [URL] [DELETE]        [Reply] [Email]  
  • jubilee pto won't engage
  • Good Afternoon All: Problem with PTO, won't engage. New tractor to me, the cap was rusted on so I didn't get a look at it when buying, just assumed it worked. You know what they say about assuming? Anyway, too late to complain. The shaft turns by hand now but needed help with a pipe wrench to get it to move. The engagement handle is slightly bent backwards indicating that someone tried real hard to make it engage. If you press hard on the handle you can feel very slightly a spline rotating but the handle appears to be in the rear, engaged position. You cannot move the handle forward.
    Any suggestions as to the cure?

    5224

    Tim Daley(MI)    Posted 04-30-2019 at 04:42:50 [URL] [DELETE]        [Reply] [No Email]  
  • Re: jubilee pto won't engage
  • You posted on our ADS forum. Move it over to the regular N-BOARD. Also, if you don't have the manuals, get them. You need to know how to correctly and safely operate your machine. Did you engage the clutch? Clutch mist be engaged first. Then advance the PTO lever to engage it? Why are you using a pipe wrench??? That's like giving a monkey a hand grenade. The PTO cover has nothing to do with the function of the PTO shaft. It is only there as a safety feature; to protect the operator from getting clothing caught in it wen spinning. Take some PB BLASTER and spray around the cap threads several times day for a few days then try to loosen it.

    Tim Daley(MI)

    [Back] [Return to Top of Forum]


    Top