Re: Water pump?

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Tom on June 11, 2017 at 16:37:52 [URL] [DELETE] :

In Reply to: Water pump? posted by Tom on June 11, 2017 at 12:45:56:

Again,thanks to aLl. Really helps to have this kind of feedback.
Here's what I've come up with. Won't replace the water pump! Got a little more aggressive with shop vac, made a "nozzle" with some duct tape and blew a good bit of seeds, dust, etc out of the radiator. More than I thought would be there anyway. So, that will help.
The alternator mount and tension and isn't factory and the geometry of the adjustment atm isn't right. I'm going to need to work up a "fix", maybe some sort of mending plate. That's the only way I can get more tension on the belt. Makes sense that it must be slipping a bit anyway as it is very loose. Way more than 1/2 to 1" for sure.
pump is dry and right so I'm not going to need with it.
Don't feel like an hour roundtrip to the hardware store today so I'll pick something up later this week and see what I can come up with.
Thanks again. Really very much appreciate all the input and the time you all took to respond.


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]