2n water pump and cooling system

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Steven P Frysinger on May 02, 2018 at 18:48:16 [URL] [DELETE] :

Folks, I've just (finally) gotten the water pump off my 2n (had to find a 13/32" box wrench to remove the fan!).

I'm replacing it because it was overheating, but the bottom hose was cold (suggesting no flow through the pump). I flushed the radiator and water flowed freely out the bottom, so I figured it must be a worn pump.

But before I put the new water pump on, I wondered if I should flush the coolant channels in the block. Is it likely for that circuit to get plugged? If I should do it, how? Just a hose in the top? Should I put the new pump on first, or wait?

Yeah, too many questions, but I want to get this right - I need my old friend back in service ASAP!

Thanks!
Steve


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]