Ford 2 n with 12 volt system not charging

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Will on June 11, 2018 at 22:39:27 [URL] [DELETE] :

Yesterday I bought a 1945 ford 2 n that was converted to 12 volt system 20 years ago.
When I bought it yesterday it started up fine but when we trailered it home it started on the trailer then it wouldn't start the next time we tried to start it. So we jumped started it with car battery.
Today had to jump start it again and put voltage meter on it and tested battery when not running reads about 12.3 volts then after jumping it to start the voltage meter reads about 12.0 volts. So I don't think system is charging.
How shall I isolate this non charging issue?
1. Charge battery
2. Try different battery
3. Buy longer battery ground cable and ground battery to an engine bolt? Currently the battery ground cable goes to a bolt on inner hood going into steering box
4. Some how test alternator and voltage regulator.
I am not an electrical genius so any advice is appreciated.


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]