Backfires

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Cal Sexsmith on October 17, 2018 at 20:05:35 [URL] [DELETE] :

I have a 1948 8N with front mount distributor and converted to 12 volts about 3 years ago. Put on a new carburetor two years ago. It has been starting and running reasonably well since the new carb. It wasn't used during the month of September. I tried starting it in early October and it took a long time to get going but finally started. I ran it for about 15 minutes, although it seemed to be running rough, and then it stalled and wouldn't re-start. I left it for a bit and tried again, I flooded it so I pulled out the plugs and cleaned them. It then started but was almost continuously backfiring. I put in new plugs and the problem remained. It also seems to be flooding very easily. Any ideas?


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]