more 600 questions

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Jon Calder on September 23, 2019 at 08:38:02 [URL] [DELETE] :

Thank all for the fuel valve answers..
Some new questions- trying to get ammeter working found seems to be original Ford ammeter not connected. Behind gauges (dash?) there is a rats nest of wires taped, screwed and otherwise incorrect. No terminal block.
Have new ammeter (the tractor does charge) and ordering new wiring harness but- where does the terminal block mount? No idea where it goes.

Tractor is 620 model s/n 1039.

Seems to have Sherman AND Howard transmissions. Very odd. If anyone curious about that I can try to figure out how to post photos.

Last question (for now) would like to have proofmeter. I would have to cut hole in dash or get an original (dash)but bigger question is where does drive connect? I think back of hydraulic pump? Would the correct guts be in place?

I do have a manual and parts book but some subjects seem to be missing. Ordered a new one.
Many Thanks!


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]