New carb seems not to get fuel after running a while

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Ron on June 25, 2023 at 14:08:38 [URL] [DELETE] :

Hi All,
My Ď41 9N with a new TSX33 carb has been acting up on me after I run the tractor for a while, quits, and will not start again until I drain the float bowl, bleed the fuel line by undoing it from the carb, drain the line out. I have undone the sediment bowl, checked screen and fuel flow so many times, I wore out the cork gasket and got a new one. Fuel flow seems to be good. I checked the vented tank cap and thatís ok. I even tried to start the tractor with the cap off, still no luck. I even blew out the lines with compressed air. But, when I put the lines back together, it fires right up, with little or no choke, and idles smoothly. Something is not allowing fuel to flow freely at times. I am figuring that the screen in the tank may have stuff blocking it maybe. But, fuel flows freely. Only after I run it for a half hour or so it sputters and quits.

I checked the spark with my spark tester, and although looks somewhat weak, I attribute that to having a 6 volt system. The spark is still there showing on my spark tester, even during the non starting episodes that happen.

Follow Ups:

Post a Followup:
Name   : 
E-Mail : 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : Link Title : Website Title Optional Image URL:
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]