Generator causing a miss

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Jeff on September 20, 2023 at 06:31:40 [URL] [DELETE] :

This is my first post I am a newbie so I apologize if I'm doing something wrong or am in the wrong forum. So here goes. Just bought a 52 8n. Runs fine but doesn't charge. It's a 12v positive ground with a 2 brush generator. I did the tests I read in another post, determined the voltage regulator was bad. Bought a 12v regulator from a well used business. Installed it. Flashed it. The generator charges as it should. Now the problem. At idle it runs fine and charges. As I speed up the rpms it misses bad. To the point it almost stalls. The coils positive wire is going to the distributor as I believe it should. If I shut it down. Pull the field wire off the generator and start it back up it runs fine. I replaced the bearing and the bushing in the generator and the pulley spins fine. The belt and tension is correct. Any ideas would be greatly appreciated.


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]