N Board Forum - Expanded Thread Page

Subject: rough running 2n

[Back] [Return to Top of Forum]

Ray Piantanida    Posted 03-02-2017 at 14:40:20 [URL] [DELETE]        [Reply] [Email]  
  • rough running 2n
  • I have a 2n that generally gives me no trouble at all. Yesterday I started it and it ran smooth for a couple minutes. Then it started to run rough and black smoke was coming from the tail pipe. I had to increase throttle to keep it running. I decided to shut it down and do some further checking later in the day. My shut-down procedure begins with closing the fuel shutoff. Almost immediately after shutting off fuel the engine smoothed out. I opened the shu off and it ran rough again. Any ideas on my problem? Seems like fuel delivery but looking for guidance from you experts.

    Ray

    R Geiger    Posted 03-02-2017 at 15:00:23 [URL] [DELETE]        [Reply] [No Email]  
  • Re: rough running 2n
  • Sounds like the float needle may be sticking open flooding carb. try tapping on side of carb with wooden handle

    John in Mich    Posted 03-02-2017 at 20:36:22 [URL] [DELETE]        [Reply] [No Email]  
  • Re: rough running 2n
  • You might also check the air intake. Is your intake above the hood or inside the hood? Air filter assembly needs regular service. It is amazing how much dirt they trap. I had a 2N missing the top of the filter and the screen. Raw dirt had been sucked into the oil bath area for who knows how long. After cleaning out the oil bath, I put a paper filter from a Kohler 10hp engine and then I drilled a hole through electrical box cover plate and placed it over the top with a wingnut.
    May not be your problem but needs to be considered.

    Ray Piantanida    Posted 03-02-2017 at 18:06:10 [URL] [DELETE]        [Reply] [Email]  
  • rough running 2n
  • Thank you Mr. Geiger. I'll give it a shot.

    [Back] [Return to Top of Forum]


    Top