N Board Forum - Expanded Thread Page

Subject: Jubilee

[Back] [Return to Top of Forum]

JR in AR    Posted 04-03-2020 at 22:50:41 [URL] [DELETE]        [Reply] [Email]  
  • Jubilee
  • My son and I are going to finish the year down on the Jubilee motor tomorrow, but we do have another issue that we haven’t quite figured out...

    We dropped the pan with the oil in it because we couldn’t get the drain plug to break loose. I cleaned the pan well and have had PB Blaster soaking around the threads for the past week. It doesn’t look rusty. I think it is just that tight. Any ideas for getting it to break loose?

    JMOR    Posted 04-04-2020 at 05:45:30 [URL] [DELETE]        [Reply] [No Email]  
  • Re: Jubilee
  • heat & cool & repeat

    Dead Eye Dave    Posted 04-04-2020 at 04:22:00 [URL] [DELETE]        [Reply] [No Email]  
  • Re: Jubilee
  • Well, I just used the largest pipe wrench I could find. Mine came free with some urging. It may be easier when pan is reattached. Good luck.

    JR in AR    Posted 04-04-2020 at 21:09:11 [URL] [DELETE]        [Reply] [Email]  
  • Re: Jubilee
  • We did get iit to loosen today. We put a 2x4 block under the side of the pan, used the wrench with a 4’ cheater and had son stand on the side of the pan. This was after heating and cooling five times. It took all my weight on the cheater. I also showed him the poor mans way to pull the crank shaft pulley. We ran out of time but are now ready to pull the engine. All other bolts/nuts are broken loose.

    JMOR    Posted 04-04-2020 at 23:28:48 [URL] [DELETE]        [Reply] [No Email]  
  • Re: Jubilee
  • good for you all

    [Back] [Return to Top of Forum]


    Top