N Board Forum - Expanded Thread Page

Subject: jubilee has no lift

[Back] [Return to Top of Forum]

Doug    Posted 11-19-2021 at 07:19:33 [URL] [DELETE]        [Reply] [Email]  
  • jubilee has no lift
  • 1953 jubilee has zero lift nothing. checked the oil found it to be very milky. cleaned that up put new oil in and still nothing. i am getting oil at the pump. any suggestions on what to look for.
    on another note how have you guys disposed of milky oil?

    Doug    Posted 12-03-2021 at 07:40:10 [URL] [DELETE]        [Reply] [No Email]  
  • Re: jubilee has no lift
  • finally got it back together after making the correct adjustments and finding the cam following pin was worn almost half away. the lift goes up and down. up is a little jerky but its ok for now. new thing though, that funny little cotter pin sticking out the bottom of the tractor has oil actively dripping from it. by the dip stick i did not over fill the oil. could this be a transmission seal? its clean new oil doesn't match the engine oil.

    Carl    Posted 11-21-2021 at 09:21:48 [URL] [DELETE]        [Reply] [No Email]  
  • Re: jubilee has no lift
  • Do you have the PTO engaged? Milky oil signifies that water has contaminated the system. Simply draining it and putting fresh oil in isn't the solution. You need to investigate why that happened. If water got in and froze then you tried to operate the tractor like that, you could have cracked and/or damaged the pump. Sometimes all you need is to replace the safety relief valve but a good inspection is recommended.

    JMOR    Posted 11-21-2021 at 17:42:40 [URL] [DELETE]        [Reply] [No Email]  
  • Re: jubilee has no lift
  • You are thinking 2N, 9N or 8N and his Jubilee's pump runs off the engine camshaft, thus PTO engaged or not, matters not.

    [Back] [Return to Top of Forum]


    Top